
How to prepare subtitles for Netflix with EZTitles 
 

 

This manual will show you how to create a TTML subtitles file with EZTitles which meets Netflix's 

requirements. In the process, we are going to use a short sample file in the SRT format which we 

have prepared in advance as well as short video clip for pure demonstration purposes.  

In this manual, we'll go to through several steps starting with the setup of the Project Settings in 

EZTitles, then going through quality control checking and at the end we will export subtitles into 

TTML file.  

 



Project Settings – Set up 
 

So, the first step will be to start new Project in EZTitles and ensure that its parameters are set accordingly 

and conform to the requirements in the current edition of Netflix' Style Guide. 

Right now, we are using  the Style Guide  from  November 2020  and  it might be a good idea  to  double 

check everything with the most recent edition of the documentation first: Netflix’ Timed Text Style Guide 

 

Project Type 

 
Now let's start EZTitles and open the File->Project Settings menu. We need to select  

➢ Open/DVD for Project Type; 

➢ Native for Mode; 

➢ None/HD/NLE for Authoring System. 

➢ All Netflix Glyphs for Charset. 

This set of options is best suited for the job we need to do right now, but you can find more about each 

one of them in EZTitles' full Help. 

After that make, sure to select the Video Format (resolution), Frame Rate and Timecode Standard options 

according to your materials. For the purpose of this manual we're going to use video in 1920x1080 

resolution running at 23.976 fps. Please note that when the video is running at 23.976 fps, 24 frames/sec 

Timecode Format must be selected:  

 

https://partnerhelp.netflixstudios.com/hc/en-us/articles/215758617-Timed-Text-Style-Guide-General-Requirements


Safe Area 
 

Once we're done with these, we can move to the Safe Area one where we can set the maximum number 

of characters each one of the text lines in the subtitle file may contain. Please mind that this option may 

be different for each individual language, so make sure to check with the Style Guide first. In this case 

we're preparing subtitles in English and that's why we enter 42: 

  

 

 

You can leave all of the remaining options to their default values. 

 



Fonts 
 

From the Fonts menu, we can change the display font and size for the subtitles.  

Again, please keep in mind that the choices we make here depend on the requirements for the specific 

language in the Style Guide. In our case, for subtitles in English, the font must be Arial and the chosen size 

shall allow 42 characters to be entered in one text line. Thus, for project in full HD resolution the font size 

shall not exceed 52px, all other options may be left to their defaults, like this: 

 

 

If you're working on subtitles in Arabic or Hebrew you should not forget to also switch the Right to Left 

option on. Otherwise the punctuation and other characters may appear incorrectly on the screen. 

 



Subtitles Defaults 
 

From the Subtitles menu, you can select what the default attributes of your subtitles will be. Please make 

sure that they will be Centered, as this is the default text position according to the Style Guide, and also 

that the Auto Centered Left Alignment and Zero Subtitles are switched off.  

 

 

The Input Language option is related to the Spell Checking so you can set it to English in this case. 

You can choose Outline as the default effect but you should also keep in mind that it will affect only the 

text's presentation in EZTitles for convenience and better readability of the text. The Netflix TTML format 

currently doesn't support Outline effect.  

The Style Guide strictly doesn't allow the use of Box effect and you should leave it switched off, unless you 

are instructed otherwise. 

 

 

 

 

 

 

 



Effects 
 

Next will be to choose the default color for the subtitles you insert in the file. So, go to Effects and set      

the Text Color option to White (255, 255, 255). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Reading Speed 
 

The Reading Speed menu allows you to set the desired for your subtitles reading speed. Reading speed 

can be measured as both Words Per Minute (WPM) and Characters Per Second (CPS) but the particular 

values you need to enter depend on the specific requirements for each particular language and target 

audience. In this case we enter 20 CPS.  

 

 

We should also activate both "Count spaces" & "Count punctuation" options as per Netflix requirements. 
 
We recommend using Character Count as the representation option and also setting the Upper Limits for 

both the Indicator in the editor and the Checks to 100% to ensure that there are no subtitles exceeding 

the specified Reading Speed. 

 

https://partnerhelp.netflixstudios.com/hc/en-us/articles/115001352212-How-is-reading-speed-measured-Do-punctuation-and-spaces-count-


Cues 
 

And finally, you may need to verify  the  contents  of  the  Cues  menu  and  define  Min.  Interval between 

subtitles, Min. & Max. Duration of a subtitle, Shot Changes Snap values of Before Cut & After Cut, 

as well as Snap to shot changes on set cues values of Threshold and Gap. 

 

 

 

According to the Style Guide, the Min. Interval should be 2 frames. 

And regarding subtitles snapped to shot changes we need to set the Before Cut interval to 2 frames and 

After Cut to 0 frames. 

Configuring the Min/Max Duration parameters might appear a little tricky at first because the Style Guide 

gives them in "seconds" while in EZTitles they are measured in "frames". But calculating from seconds to 

frames is quite easy in fact. The Timecode Format that we set in the beginning will give us the number of 

frames there are for one second and in this case, we have 24 frames per second. 

So, the Min. Duration = ⅚ * 24 = 20 frames, respectively the Max. Duration = 7*24 = 168 frames. 

* In versions prior to EZTitles 6 these options are situated in Edit > Preferences > Command options > Cues 

Activate   Snap   to   shot   changes   on   set   cues   and   set   Threshold   to   11   and   Gap    to    0   frames. 

This way when you insert In/Out cues and they are placed less than 12 frames away from the shot change, 

they will be automatically snapped to it according to Before Cut & After Cut values. 

 

 

 



Now, the Project Settings have been properly set up we can continue with the next step – to perform 

couple of Quality Control checks on the subtitles file and verify that it meets all requirements of the Netflix 

Style Guide. But before that it might be quite useful to create Project Settings Template which we could 

load in any later point if we need to check or create subtitles complying with the same requirements.  

To do so simply go to the Project Settings menu again, click on the New button there, enter a name for the 

new Template and press OK to save it.  

 

 

 

Then when you want to load the same template, simply select its name on the left side pane and press the 

OK button on the Project Settings menu to confirm the action. For more information, how to create or 

import subtitles from external file and how to load a video clip in EZTitles you may refer to the program's 

full manual or check our dedicated video tutorial here: https://www.youtube.com/watch?v=ZbSU-Ey7EBw 

 

https://www.youtube.com/watch?v=ZbSU-Ey7EBw


Quality Control  
 

Verification 
 

No matter if you are working on the subtitles from the scratch or you are loading them from a previously 

created file, we recommend you to run couple of Checks before you export them into a new file. EZTitles 

offers quick and easy to use way to verify against multiple issues simultaneously.  

To perform a quality control check, go to Titles->Check Subtitles where you should first select the required 

criteria.  

 

 

In this case we are working on subtitles which will be delivered to Netflix so you may want to use the 

following: 

➢ Inconsistent Cues – this is a basic check against subtitles with overlapping In/Out cues 

which are in general unacceptable; 

➢ Duration – verifies that there are no subtitles longer or shorter than the Min/Max 

Duration parameters specified earlier; 

➢ Above Reading Speed – checks if there are subtitles which exceed the reading speed limits 

set earlier. In other words, if there are subtitles which are unnecessary long; 



➢ Below Reading Speed – checks for subtitles which are under the reading speed limits, i.e. 

subtitles which remain on the screen for too short and the viewer might not read them; 

➢ More than 2 lines – verifies that there are no subtitles containing more than 2 text lines; 

➢ Gap between Subtitles less than 12 frames – checks for subtitles set on distance greater 

than the specified Min. Interval and less than 12 frames. Finds any gabs of 3-11 frames 

between subtitles that must be closed to 2 frames. 

➢ Non-printable characters – checks if there are characters, which are not included in 

Netflix glyph list. Non-printable characters are marked as "□". 

As it comes to Shot Changes, we should check if the subtitles follow the rule for not placing cues less 

than 12 frames form the shot changes as set in Project Settings. 

To verify if your subtitles comply with this rule, you have to first set Before and After Cut intervals as 

explained in section Cues and then to correctly configure the Snapped to Shot Changes option in       

Shot Changes section in Check Subtitles: 

 

 

 

 

 



And just to be on the safe side you can also use the options from the Attributes section to verify that all 

subtitles are aligned to the center of the screen and are white in color: 

➢ Color is not White – checks for subtitles which are not White in color; 

➢ Alignment is not Center – checks for subtitles which are not aligned to the center of the 

screen. 

 

 

The Previous and Next buttons will help you navigate through all subtitles which are found as problematic. 

By pressing the Log button all problematic subtitles will be send to the so-called Log List. 

 



Fixing subtitles with issues 
 

After running the checks, we'll have pretty good idea about the subtitles which don't comply with the   

Style Guide requirements and instead of modifying them by hand, one by one we can use the                    

Titles->Fix Subtitles options. 

First you need to select the range of subtitles for which the Fix Subtitles options will be applied. As you can 

see there are plenty of options like All Subtitles, those in the Log or Draft lists, etc. Right now, we're going 

to Fix only the subtitles in the Log list, those we already identified that have some sort of issues: 

 

 

 

➢ Fix Below/Above reading speed – automatically adjusts the subtitles' Out cue if the 

subtitle doesn't meet the Reading Speed parameters and is reported as Below/Above the 

Reading Speed limits set on the Project Settings menu; 

➢ Fix Intervals – changes the distance between the subtitles to match the Min. interval if 

the distance is less than specified threshold interval; 

➢ Fix subtitles below/above min./max. duration – automatically adjusts subtitles' Out cue 

if the duration is above the maximum or below the minimum duration parameters 

specified at the Project Settings menu; 

 



➢ In Shot changes tab activate Netflix mode option. 

 

Selecting the Netflix mode option will run the Fix with pre-defined parameters compliant to the latest 

Netflix specifications: 

• In-cues starting on the shot change or 11 frames after it will be snapped to the shot change. 

• In-cues starting 8 frames or less before a shot change will be snapped to the shot change. 

• In-cues starting 9, 10 or 11 frames before a shot change will be moved to 12 frames before 
the shot change. 

• In-cues starting 12 frames before or after a shot change will not be moved. 

• Out-cues ending up to 11 frames before a shot change will be snapped 2 frames before the 
shot change. 

• Out-cues ending up to 11 frames after a shot change will be snapped 2 frames before the shot 
change if the Reading Speed allows it, or will be moved to 12 frames after the shot change. 

 

Please keep in mind that sometimes it might not be possible for EZTitles to automatically adjust all 

subtitles, there might be really complicated situations with two or more options conflicting with each 

other. That's why we always recommend running another Check and eventually fixing these subtitles by 

hand. 

Both the Check Subtitles and Fix Subtitles enables you to save the activated options as Presets for later 

use.  

https://partnerhelp.netflixstudios.com/hc/en-us/articles/360051554394


Subtitles reported by the Check Subtitles function as not aligned to the center or such in different color 

can easily be formatted back to the preferred style by using the Titles->Format options.  

Considering that all subtitles in the output file must be positioned to the center and contain only white 

text it would be better to change the alignment and color for all subtitles, just to be on the safe side, like 

this: 

 

 

 

 

 

 



Exporting TTML file for Netflix 
 

Once we checked everything, if the subtitles play in perfect synchronization with the video, if there are 
subtitles which doesn't meet any of the specific requirements, we can proceed forward and export 
compliant TTML subtitles file.  

Press on File->Export and select the Netflix Timed Text (NLFX-TT) option from the list.                                       
Then the related Netflix Timed Text export options dialog will pop up asking you to specify just a few things 
before the TTML file has been created. 

 

 
Please make sure to select the correct language from the respective drop-down menu. Otherwise if the 
language is not correct Netflix's automated QC system will reject the file.  

Usually all delivered subtitles must start from the 00:00:00:00 and if you have missed to Recut them earlier, 
you can do that from the export menu by entering the Start Timecode of your video in the Media Start 
Timecode field. And if you have already Recut your subtitles or they don't need to Recut at all, please mind 
to enter 00:00:00:00 for it to prevent any modifications of the timing in the output file. If you choose the 
Auto option the file will be automatically Recut to 00h. 

Selecting the correct Timebase is also very important. You can determine whether to use Media Time or 
SMPTE Timecode by checking with the Netflix guide on this subject. 

All other options can be set to their default values or modified per your own preference and requirement. 

 

 

https://partnerhelp.netflixstudios.com/hc/en-us/articles/215131928-How-do-I-know-whether-to-use-SMPTE-or-MEDIA-in-the-manifest-for-timing-

